Gaussian Point Splatting
Article URL: https://momentsingraphics.de/Siggraph2026.html
Comments URL: https://news.ycombinator.com/item?id=48396792
Points: 3
# Comments: 0 ⌘ Read more
Journey to JPEG XL: open-source experiments shaped the future of image coding
Article URL: https://opensource.googleblog.com/2026/06/journey-to-jpeg-xl-how-open-source-experiments-shaped-the-future-of-image-coding.html
Comments URL: [https://news.ycombinator.com/item?id=48390688](https://news.ycombinator.com/ite … ⌘ Read more
Take Action: LAPD Removed Crime Location Data. Here’s Why It Matters
Article URL: https://blog.spotcrime.com/2026/06/take-action-lapd-removed-crime-location.html
Comments URL: https://news.ycombinator.com/item?id=48383451
Points: 4
# Comments: 1 ⌘ Read more
AI Engineers aren’t safe from being replaced by AI
Article URL: https://dmanco.dev/2025/08/17/fear-not-even-ai-engineers-will-be-replaced-by-ai.html
Comments URL: https://news.ycombinator.com/item?id=48380987
Points: 3
# Comments: 1 ⌘ Read more
Australia gets access to AI model ‘too dangerous to release’
Mythos is so good at finding software flaws that its maker won’t release it. Now Australia is on the access list. ⌘ Read more
Years ago, I used Kate, no, not somebody’s wife, but the KDE Advanced Text Editor, to export source code files and fragments into HTML with syntax highlighting. I think that’s where I got the initial <b> idea from. There were also bucketloads of <span style='color:#644a9b;'> all over the place, even inside <b>. No CSS classes defined upfront, all colors inlined. The final rendering in the browser looked great, but the source code ugly as hell in my opinion. However, I’m thankful for hinting me at <b>. I think this kicked off everything. :-)
@movq@www.uninformativ.de It’s the “Lyse types the entire HTML by hand” generator. Yes, no kidding. I write articles so rarely, that I can do that once in a while. It’s fun to some degree, but also not.
After some time, I finally recorded some Vim macros to insert <b>…</b>, <var>…</var>, <span class=s>…</span> etc. around the tokens. This helped a little bit. But I was still questioning my mental state doing it like that. I also had to fix a bunch of the end tags by hand, because the word movement wasn’t enough or the end movement went too far. Quite the annoying process for sure.
But I think the HTML looks a wee bit nicer and is maybe even semantically a little bit better than having only <span>s everywhere. I find the <span class="whatever"> just soo awfully long. Of course, I never look at the code again, but knowing, that e.g. there is a <b> and it saves so many bytes in comparison, makes me happy. It is a more elegant solution in my opinion. Not by much, but better nonetheless. It’s a matter of simplicity. Admittedly, even I can’t avoid the <span>s alltogether. Oh well. On the other hand, I’m sure that this does not make any difference whatsoever. I bet, nobody and nothing, like a screenreader, analyzes the HTML for that, where this would be truly useful.
Oh! Maybe text browsers, though. It just occurred to me while composing this reply. :-) Haha, I lost my bet quickly. w3m picks up at least the <b> for keywords and builtin types, <u> for filenames and <i> for comments. Yey. No different styles for <var> and <mark>, unfortunately. elinks only renders the bold. It’s cool that I had the right intuition right from the beginning, despite being unable to pinpoint it. :-)
All the <span> hell with common syntax highlighters is a downer for me that keeps me from looking more into them. If I wrote more articles, I might rig something up with Pygments. At least that’s somehow positively connotated in my brain. Not sure if it actually deserves it, but I dealt with that in some loose form (can’t even remember) years and years ago. Apparently, it wasn’t too terrible.
To prepare the table of contents, I used grep and sed with some manual intervention in the end. The entire process can be improved. Absolutely.
You wrote your own site generator, didn’t you?
Data centre boom could send power prices 26 per cent higher: Climate group
As Victoria and NSW chase billions in data centre capital, a report warns households could foot the bill for a dirtier, costlier grid. ⌘ Read more
[$] Caching for extended attributes
Extended\
attributes (xattrs) provide a way to attach key/value metadata to
inodes—files, directories, and the like—in a filesystem. As with many
Linux filesystems, the FUSE filesystem
supports xattrs. In a filesystem-track session at the 2026 Linux Storage,\
Filesystem, Memory Management, and BPF Summit, FUSE maintainer Miklos
Szeredi led a discussion a … ⌘ Read more
Vim Classic 8.3 released
Version\
8.3 of Vim Classic has been
released. This is the first release of the Vim fork since the project
was announced
in March.
This release is based on Vim 8.2.0148, with a number of bug fixes
and patches conservatively backported from future versions of Vim
upstream. We elected to clean up this version of Vim, prepare it for a
release, and imagine an alternate history wh … ⌘ Read more
お知らせ:JPCERT/CC Eyes「TSUBAMEレポート Overflow(2026年1~3月)」 ⌘ Read more
Crystal Nights by Greg Egan
Article URL: https://www.gregegan.net/MISC/CRYSTAL/Crystal.html
Comments URL: https://news.ycombinator.com/item?id=48364754
Points: 3
# Comments: 0 ⌘ Read more
GitHub and the Crime Against Software
Article URL: https://eblog.fly.dev/githubbad.html
Comments URL: https://news.ycombinator.com/item?id=48361064
Points: 6
# Comments: 0 ⌘ Read more
Iran stops negotiations with U.S., vows to ‘completely’ block Strait of Hormuz
Article URL: https://www.cnbc.com/2026/06/01/iran-us-negotiations-strait-of-hormuz.html
Comments URL: https://news.ycombinator.com/item?id=48357637
Points: 32
# Comments: 13 ⌘ Read more
tail -f access.log looks like a Matrix screensaver at the moment. Whoooooosh …
@arne@uplegger.eu Indeed. I’m glad that it’s all just static HTML. The most expensive part about this is probably TLS. 🤷♀️
London’s Free Roof Terraces
Article URL: https://diamondgeezer.blogspot.com/2026/05/londons-free-roof-terraces.html
Comments URL: https://news.ycombinator.com/item?id=48343714
Points: 5
# Comments: 0 ⌘ Read more
Feeling the chill? These are the best portable heaters to keep you toasty
From cheap convector panels to cutting-edge far infrared units, what’s the best kind of fan-free portable heater for your home? ⌘ Read more
Ahoy, DECmate II the little PDP-8 that could
Article URL: http://oldvcr.blogspot.com/2026/05/ahoy-decmate-ii-little-pdp-8-that-could.html
Comments URL: https://news.ycombinator.com/item?id=48343078
Points: 3
# Comments: 0 ⌘ Read more
‘Here to stay’: The numbers behind the NFL’s major Australian gamble
With 8.8 million local fans and a confidential cheque from Victorian taxpayers, American football is taking on the AFL and NRL. ⌘ Read more
Microcode inside the Intel 8087 floating-point chip: register exchange
Article URL: https://www.righto.com/2026/05/microcode-inside-intel-8087-floating.html
Comments URL: https://news.ycombinator.com/item?id=48338656
Points: 10
# Comments: 1 ⌘ Read more
Haha, someone had a similar idea … https://lpcvoid.com/blog/0018_why_i_am_against_genai/index.html
Nesbitt: Protestware for coding agents
Andrew Nesbitt has written a blog\
post detailing a recent incident with the jqwik library for property-based testing
in Java. On May 25, the 1.10.0 release of jqwik included a change
that attempts to instruct coding agents to disregard previous
instructions and delete jqwik tests and code.
I think this is a new class of supply-chain input worth ke … ⌘ Read more
<updated> of the feed, too. But for some reason, some articles were suddenly marked as new.
Aha, yesterday’s newly added support for LC_TIME to render localized timestamps also broke the feed parsing with my LANG=de_DE.UTF-8 and LC_CTYPE=de_DE.UTF-8 environment. :-)
Atom feeds make use of RFC 3339 timestamps. They are first converted into RFC 882 timestamp representation, which is the one that RSS feeds use. However, this conversion now results in localized RFC 882 timestamps, which cannot be parsed into Unix timestamp numbers via curl_getdate(…). I bet that it doesn’t know about the localization at all and expects English month and weekday names. Looking at its docs, I reckon that function was selected because of its myriad of supported timestamp formats: https://curl.se/libcurl/c/curl_getdate.html RFC 3339 is not included, though, hence the transformation up front.
The intermediate Item objects in the parser domain use std::string for the timestamp representation. This isn’t all that silly, because Newsboat supports all sorts of different feed formats with different timestamp formats. These RFC 883 timestamps are centrally parsed into time_t.
Speaking of time: It’s time to go to bed after this late bug hunting fun. :-)
@lyse@lyse.isobeef.org Uhhh, yes, I have one single script to build the website and I ran that while writing that noai.html page. Apart from the global updated field in my feeds (that one got changed), everything else should be stable, though.
Maybe this helps narrow things down? 
Google’s plan to run your life could break the internet
The tech giant’s new AI overhaul is set to have damaging ramifications. ⌘ Read more
OMG, most of today’s new slang goes unspoken
Where Romeo and Juliet once uttered pledges on the QT, serenading in shadows, the modern Romeo is as likely to slide into Juliet’s DMs. ⌘ Read more
Justice Dept. Is Said to Open Criminal Inquiry of E. Jean Carroll
Article URL: https://www.nytimes.com/2026/05/27/us/politics/criminal-inquiry-e-jean-carroll-trump-accusations.html
Comments URL: https://news.ycombinator.com/item?id=48303131
Points: 17
# Comments: 4 ⌘ Read more
On Labubu and the Hyperreal
Article URL: https://2earth.github.io/website/20260525.html
Comments URL: https://news.ycombinator.com/item?id=48299335
Points: 3
# Comments: 0 ⌘ Read more
The VibeSec Reckoning
Article URL: https://martinfowler.com/articles/vibesec-reckoning.html
Comments URL: https://news.ycombinator.com/item?id=48294670
Points: 4
# Comments: 0 ⌘ Read more
I’ve started collecting reasons against AI usage here, so I don’t have to repeat myself all the time:
Mini Micro Fantasy Computer
Article URL: https://miniscript.org/MiniMicro/index.html#about
Comments URL: https://news.ycombinator.com/item?id=48291947
Points: 4
# Comments: 0 ⌘ Read more
James Bond’s battle with AI is his most human story yet
As Amazon tries to decide a cinematic future for a broken icon, a new video game provides the best 007 experience in decades. ⌘ Read more
The $180m payday that ‘meme king’ didn’t share with most staff
He’s the face of the viral “co-founder Albo” campaign. He’s also the founder whose $180 million exit handed a payday to a tiny circle while other staff were kept in the dark. ⌘ Read more
@itsericwoordward@itsericwoodward.com Confess, you just registered as {{first_name}}!
Nobody checks their e-mail templates. And even if they do, they only look at the HTML part. The plain text part is useless more often than not. Granted, this is the subject.
Yoti age checks share facial photos and device fingerprints with third parties
Article URL: https://techxplore.com/news/2026-05-online-age-pointless-privacy.html
Comments URL: https://news.ycombinator.com/item?id=48271327
Points: 3
# Comments: 0 ⌘ Read more
Magnifica Humanitas (Encyclical Letter)
Article URL: https://www.vatican.va/content/leo-xiv/en/encyclicals/documents/20260515-magnifica-humanitas.html
Comments URL: https://news.ycombinator.com/item?id=48265206
Points: 41
# Comments: 9 ⌘ Read more
Are chatbots making things more difficult than old-fashioned transactions?
These days as consumers, we are often locked into these false amities with chatbots, our to-and-fro reliant on what previous questions and responses have been digested by the software. ⌘ Read more
The Eternal Sloptember
Article URL: https://geohot.github.io//blog/jekyll/update/2026/05/24/the-eternal-sloptember.html
Comments URL: https://news.ycombinator.com/item?id=48263238
Points: 41
# Comments: 5 ⌘ Read more
I just missed the 20 year anniversary of my blog. 😬 What a stupid long time to do this.
This started out as a PHP page with user comments, MySQL as a database, a PHP webadmin … can you believe that? Totally unnecessary. But everything was “LAMP” back then, so that’s what I was using as well. I kicked out MySQL in 2011 (it just stored files since then) and eventually switched to static HTML pages in 2015.
RSS feeds have only been there since 2009, because I was late to the party. For a long time, I didn’t understand what they were good for. 🤦
Mastering Dyalog APL
Article URL: https://mastering.dyalog.com/README.html
Comments URL: https://news.ycombinator.com/item?id=48256475
Points: 4
# Comments: 0 ⌘ Read more
Microsoft Flight Simulator’s new collaboration with NSW Rural Fire Service
The NSW Rural Fire Service has teamed up with Microsoft for a new aerial firefighting mission in Flight Simulator. 9news.com.au spoke to the game’s director, Jörg Neumann, to learn all about it, and how they’ve used a million-dollar camera to capture real life locations for the game. ⌘ Read more
Limerick
Article URL: https://www.worldwidewords.org/surprise.html
Comments URL: https://news.ycombinator.com/item?id=48254684
Points: 5
# Comments: 0 ⌘ Read more
What you need to know about VPNs in 2026
The technology is increasingly being used to dodge age and verification checks in Australia. But how does it work, and is it legal? ⌘ Read more
My I3-Emacs Integration
Article URL: https://khz.ac/software/i3-integration.html
Comments URL: https://news.ycombinator.com/item?id=48252535
Points: 3
# Comments: 0 ⌘ Read more
Don’t Roll Your Own
Article URL: https://susam.net/do-not-roll-your-own.html
Comments URL: https://news.ycombinator.com/item?id=48252192
Points: 6
# Comments: 1 ⌘ Read more
Reverse engineering circuitry in a Spacelab computer from 1980
Article URL: https://www.righto.com/2026/05/reverse-engineering-spacelab-computer.html
Comments URL: https://news.ycombinator.com/item?id=48248954
Points: 9
# Comments: 1 ⌘ Read more
How to convert between wealth and income tax
Article URL: https://paulgraham.com/winc.html
Comments URL: https://news.ycombinator.com/item?id=48237422
Points: 7
# Comments: 0 ⌘ Read more
FSFE intervenes against Apple before EUCJ for the second time
Article URL: https://fsfe.org/news/2026/news-20260519-01.en.html
Comments URL: https://news.ycombinator.com/item?id=48233939
Points: 5
# Comments: 0 ⌘ Read more
‘Huge validation’: Trump administration backs Aussie quantum tech
Two of Australia’s most prominent quantum names have been drawn into the Trump administration’s growing portfolio of strategic technology companies. ⌘ Read more
OpenBSD 7.9 released
The OpenBSD 7.9 release is
out, right on schedule. There is the usual long list of new features,
including improved architecture support, CPU scheduling on heterogeneous
systems, the ability to hibernate a suspended system after a configurable
delay, socket splicing, a
__pledge_open()
system call giving special access to the C library, and much more. See the
announcement and [the full\
changelog]( … ⌘ Read more